Linux – Eclipse – „Could not load SWT library“

Problem:

java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons: 
	no swt-gtk-3740 in java.library.path
	no swt-gtk in java.library.path
	Can't load library: /home/user/.swt/lib/linux/x86_64/libswt-gtk-3740.so
	Can't load library: /home/user/.swt/lib/linux/x86_64/libswt-gtk.so
cat /home/user/.eclipse/org.eclipse.platform_x.x.x_xxxxxxxxx/configuration/xxxxxxxxxxxxx.log

 

sudo apt-get install libswt-gtk-3-jni libswt-gtk-3-java

 

sudo cp /usr/lib/jni/libswt-*3740.so ~/.swt/lib/linux/x86_64/

Schreibe einen Kommentar